/ laravel

Как изменить версию composer: обновиться или откатиться на старую версию

С выходом второй версии composer, теперь она устанавливается по-умолчанию. Однако, некоторые приложения могут быть не полностью совместимы с 2 версией композера, поэтому вам, возможно, придётся использовать первую версию до тех пор, пока все несовместимости не будут устранены.

Именно из-за этого, в некоторых старых приложениях на Laravel вылетает ошибка: Laravel PackageManifest.php: Undefined index: name. Для того, чтобы исправить эту ошибку, нужно просто отказаться от использования второй версии composer и понизиться её до первой версии.

Чтобы понизить версию composer

Если по каким-либо причинам вам необходимо понизить версию композера (composer) до первой версии, вы можете выполнить следующую команду от имени root:

sudo composer self-update --1

Как обновить composer до 2 версии

И, в обратном порядке, когда ваше приложение будет готово к обновлению, чтобы обновить composer до 2 версии, выполните команду от имени root:

sudo composer self-update --2

Как узнать версию composer

Если вы не знаете наверняка, какая у вас версия composer, то для того, чтобы проверить установленную версию композера, выполните в консоли команду:

composer

Затем проскрольте в самый верх, к надписи composer, где вы и увидите текущую версию композера:
composer_v